VMware Solutions Discussions

vSphere plug-in Manager showing warning message after VSC 4.2.1 uninstallh


Any idea how to clear the following warning message. Attached the screenshot as a word document. Basically the VSC plug-in shows the status as 'disabled' in the Plug-In Manager with following error message...

"The following error occured while downloading the script plugin from https://<vcenter_server_name>:8143/vSphereExtensionDescriptor.xml; The request failed because of a connection failure. (Unable to connect to the remote server)."






I'm assuming that you removed VSC without removing the plugin's registration from vCenter.  Have you tried using the Managed Object Browser to unregister the plugin?

VMware has documented the process here: http://kb.vmware.com/kb/1025360

Hope that helps.


If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.


I have the same issue with VSC 4.2 on Vcenter 5.5 client.  I can connect to 3 other vcenters with the client using the NetApp VSC 4.2 plugin with no issue but one of them will not work.  So it now shows enabled but is not working for connecting to one vcenter.  I keep getting this error :


Virtual Storage Console
NetApp, Inc.
Virtual Storage Console for VMware vSphere
The following error occured while downloading the script plugin from https://XXX.XXX.XXX.XXX:8143/vSphereExtensionDescriptor.xml: The request failed because of a connection failure.
(Unable to connect to the remote server)


I restarted the VSC service on the vcenter server running windows and tried again and same issue.



Did you ever figure out what the fix is for this issue?


I am trying to replace the Self-signed certificate with a CA signed cert and get the same error after i install using


NetApp KB article 1014445 Version: 2.0 "How to import an existing CA-Signed certificate into VSC for VMware"




Sorry for late reply but yes I got it fixed.  Called support and essentially uninstalled 4.2.1 and installed 4.2.2 on the vCenter server with the issue.  Here were the steps.  This kept the backup repository and configurations intact.  


shut down services
copy out repository to desktop
uninstall 4.2.1
rename D:\Program Files\NetApp\Virtual Storage Console to D:\Program Files\NetApp\Virtual Storage Console.old
install 4.2.2
use registration URL https://localhost:8143/Register.html
Add controllers (modify controller settings, etc..)
don't click on backup and recovery tab yet.
shut services down: smvi and VSC
move copied repository folder to new install location.
start services back up: smvi and VSC
open vCenter again
open NetApp
Verify controllers are OK
browse to the Backup and Recovery
Verify backups run, restores run,

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner