Active IQ Unified Manager Discussions

WFA 4.1 No longer Works with 7-mode?


I've installed WFA 4.1GA and getting "Failed to Connect to Controller" on every 7 mode box.


I tested doing a manual connection on the WFA server via powershell and it appears something is messed up with the SDK.

PS C:\Windows\system32> connect-nacontroller nas1
connect-nacontroller : Failed to load ntapadmin64 DLL
At line:1 char:1
+ connect-nacontroller nas1
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidResult: (nas1:NaController) [Connect-NaController], Exception
+ FullyQualifiedErrorId : RpcConnectionFailed,DataONTAP.PowerShell.SDK.ConnectNaController



I think it is because of the upgraded Powershell Toolkit version which uses .NET 4.5.2 version.

Install the latest .NET version it will work.







I updated to the latest .Net package 4.6.2 and this did not make a difference unfortunately.


What I have noticed is that it will connect if I provide credentials in powershell outside of WFA. Is there somehow in the WFA commands to do the same sort of thing? I tried "-Credential" in the "Connect-WFAController" command but it's not a recognized paramenter.


Working outside WFA: 

PS C:\Windows\system32> connect-nacontroller nas1 -Credential $a

Name Address Ontapi Version
---- ------- ------ -------
nas1.... 1.19 NetApp Release 8.1.3P1 7-Mode: Wed Jul 10 20:17:...




Not working in WFA (command powershell code):

param (
[parameter(Mandatory=$true, HelpMessage="Array name or IP address")]

[parameter(Mandatory=$true, HelpMessage="Share name")]

[parameter(Mandatory=$false, HelpMessage="Virtual Filer name")]

# connect to controller
Connect-WFAController -Array $Array -VFiler $VFilerName

# Check that Qtree exists
$ShareStatus = Get-NaCifsShare -ShareName $ShareName -ErrorAction SilentlyContinue
if ($ShareStatus)
$msg = "Sorry there is already a share named" + " " + $ShareName + ". " + "It is located at" + " " + $ShareStatus.MountPoint + ". " + "Make sure you entered the correct share name, try a different share name if possible, or contact a NAS team member to assist."
throw $msg


After doing some more digging I finally solved this. I found this forum article that references a registry change that needs to be applied to lower the minimum certificate length.



Edit: Long term solution is to renew the ssl key on each controller to something more than 512 bits by default. 1024 or 2048.

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.