ONTAP Discussions

7-mode: How to move root volume to flash pool?


Hi all,

a little question on migrating from older disks/shelves to newer flash pools:

I think "root vol on Flash pool (hybrid) Aggregate" was allowed and supported since DOT 8.1.2, is that correct?

I am now on 8.1.3 7-mode (tried 8.1.2 also), but:

ucnlabfiler01*> aggr status

           Aggr State           Status            Options

      aggrflash online          raid_dp, aggr     hybrid_enabled=on



          aggr0 online          raid_dp, aggr     root


I migrated all data volumes (vol move or manually) to the new Flash pool aggr. Fast and fine. But:

ucnlabfiler01*> vol options volroot_new root

vol options: Operation not permitted on a Flash Pool.


No way to get my root vol to the hybrid aggr without maintenance mode boot, i.e. downtime? Or no way at all??

Comments or hidden options welcome 😉



It's definitely a supported function as I've installed quite a few in that mode. Normally I create the Aggregate and move root first, then enable the hybrid option, not the other way around. Do you have any other mutually exclusive options (such as SnapLock) on the root volume already?


     Just tried it and a hybrid aggregate does indeed block the activation of the root flag on a volume.

     If you need to do this you would need to move the root volume BEFORE setting the aggregate into hybrid mode (and ensure you are on 8.1.2+)


     Create destination aggregate

     Move root and restart

     Confirm root is in the correct place

     aggr options <aggr> hybrid_enabled on -f

     aggr add <aggr> -t SSD <n>

Obviously this is a little late if you've already gone through most of the migration so it might be worth logging a call with NetApp support as it may be a bug (since 8.1.1 blocked shared root / hybrid completely and the command may not have been updated in the code)

Message was edited by: David McCarthy


Thanks for reply,

Yes I've also installed some new systems in that mode as well. So in 8.1 I indeed should have planned things in a different order. Already moved 50+ data volumes (8+ TB)... No fun to do that again (twice)...

However, meanwhile I was told of bug 621647 - according to that a "move of the root vol onto exisiting flash pool aggr" should work from 8.2 onwards... Can anyone confirm this?

I cannot give it a try (upgrade to 8.2) at the moment because of many SnapDrive/SnapManager dependencies...


I checked this with 8.2 but this is still not possible to move the rool volume to a flash-pool aggregate. With System Manager 3.2 as well, it is not possible to change the existing aggregate with the root volume to use disks from the SSD Pool.


There is a solution, to use Flash-Pool with a root volume and not loosing expensive hard disks for a new root aggregate.



Create a new aggregate, move the root volume on this aggregate, change to hybrid, add SSD disks.

As far as I know, this is only possible in this order using the commandline.

Good idea to take advantage of the increased max. aggregat sizes in Ontap 8.2 at the same time.



vol create vol0_new aggr1 250g

vol options vol0_new create_ucode on

vol options vol0_new convert_ucode on

vol options vol0_new no_atime_update on

vol lang vol0_new en_US

options ndmpd.enable on

ndmpcopy /vol/vol0 /vol/vol0_new

vol options vol0_new root

vol rename vol0 vol0_old

vol rename vol0_new vol0


reboot –f

vol offline vol0_old


aggr options aggr1 hybrid_enabled on –f

aggr options aggr1 cache_raid_group_size 10

aggr add aggr1 –T SSD 10







On HA-Pair you can switch root volume without downtime even to a flashpool aggregat with cf takeover.

filerB> cf takeover

filerB> partner

partnerfilerA> priv set diag

partnerfilerA> vol options <rootvol @ flashpool aggr> root -f

partnerfilerA> partner

filerB> cf giveback

This has been tested on FAS2240 with Ontap 8.1.3P3.