Effective December 3, NetApp adopts Microsoft’s Business-to-Customer (B2C) identity management to simplify and provide secure access to NetApp resources.
For accounts that did not pre-register (prior to Dec 3), access to your NetApp data may take up to 1 hour as your legacy NSS ID is synchronized to the new B2C identity.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

ONTAP Discussions

New grafana version (anything above 5.x) dashboard is not working when single value is selected


We have a grafana + grphite + harvest installation for collecting the metrics from storge. We have asked to upgrade grafana by our security team as we were using 4.5 version to latest version. I have uninstalled older version and installed a new version (5.2.1). Installation went without any issue. After upgrading, in the dashabord, whenver i select specific group, it doesnot show any value. Dashboard shows value when i select "all" and "mutiple group names". Tried re-importing the dashboards using netapp-manager/re-added graphite database, tried modifying the queries for given dashboard, none has solved the problem. Please find attachment where you can see, when "all" value is selected, dashboard shows metrics. When i select "one of the group", it shows no metrics. When i select "more thant one group", it shows metrics. I am sure this is a problem with Grafana. If someone encountered this issue and have a fix, can you please share?






After spending a lot of time and fiddling with various Grafana versions, now its seems like, the issue is not due to Grafana insteaf Graphite web (version 0.9.15) we are using. I tried using JSON query analyzer and found that, when i select "one of the group" from the drop down list, its not getting any value/data back from graphite web server. If its working as expected, then it should get back "all nodes" in the "selected group" as the response. In the attached screenshot, you can see "respnse: Array[0]" when i select a "group". I am out of ideas what could be causing this or how i can fix this. Any insight/assistance is greatly appreciated. 



NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner