Effective December 3, NetApp adopts Microsoft’s Business-to-Customer (B2C) identity management to simplify and provide secure access to NetApp resources.
For accounts that did not pre-register (prior to Dec 3), access to your NetApp data may take up to 1 hour as your legacy NSS ID is synchronized to the new B2C identity.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

ONTAP Discussions

snapmirror replication transfer failed to complete

Santosh_Pandey

Snapmirror failed to update while giving the error replication transfer failed to complete.

I have checked everything on both source and destination.It is s VSM relationship and space,hosts entry,ontap version,snapmirror.conf entry,host access are not the issues.

 

I am not able to telnet filer to filer on 10566 to check port status.

 

Any ideas?

 

Data ONTAP Release 8.1.2P4 7-Mode --------Destination

Data ONTAP Release 7.3.7P3  -------------------Source

 

 

 

16 REPLIES 16

Naveenpusuluru

Hi @Santosh_Pandey

 

Can you please check snapmirror.allow file .. both snapmirror source and entries should be there on that file. Please ask your network team to check the ports between 10565-10569.

 

Also please paste the below commands output.

 

snapmirror status -l <destination volume name>

Hello @Naveenpusuluru,

 

Below is the output:

 

Source: HORSMHDSGF02-SV:HOROFS02
Destination: HORLWHDSGF01:HOROFS02
Status: Idle
Progress: -
State: Snapmirrored
Lag: 252:19:41
Mirror Timestamp: Sat Jan 14 23:22:47 GMT 2017
Base Snapshot: HORLWHDSGF01(0118057313)_HOROFS02.248
Current Transfer Type: Update
Current Transfer Error: replication transfer failed to complete
Contents: Replica
Last Transfer Type: Scheduled
Last Transfer Size: 62076 KB
Last Transfer Duration: 00:01:09
Last Transfer From: HORSMHDSGF02-SV:HOROFS02

 

Transfer was going on previously.Don't know if ports are not open and why.

Anyway to do filer to filer telnet?

we are using snapmirror.access host option so no allow file configured.

Thanks in advance

Hi @Santosh_Pandey

 

Please look in to the logs using below command, we can trace the root cause for this snapmirror transfer failure.

 

rdfile /etc/log/snapmirror

Did not find anything specific in logs.

Any other ideas?

Hi @Santosh_Pandey

 

Are they pingable to each other?....... Some times it might be the issue with WAN also. Please reachout to your network team.

Hi,

 

The destination filer was not reachable from the source .Added entry in the hosts file.

Still unable to do snapmirror update 

Hi @Santosh_Pandey

 

It might be the problem with your network. Please reach out to network team.

This issue is only for some volumes but for other volumes snapmirror is working fine.

This is for the same filer.How can this be possible if ports are not open

Hi @Naveenpusuluru

 

Any findings on this?

can you suggest further please?

using the same ports for other replications as well.There is problem with only some of the relationships other are working fine

Hi @Santosh_Pandey

 

Can you please send me the outputs of below commands(both source and destination).

 

df -h volumename

options snapmirror

rdfile /etc/snapmirror.conf

rdfile /etc/rc

rdfile /etc/hosts

rdfile /etc/snapmirror.allow

rdfile /etc/hosts.equiv

 

snapmirror status -l destination volume name

 

ping source

ping destination

 

snap list volume name

 

I will look in to them and will try to help you.

Hi @Naveenpusuluru,

 

 

Attaching outputs

 

 

 

Hi @Santosh_Pandey

 

Everything looks good and well maintained man. Can you please send me the logs of snapmirror.

 

rdfile /etc/log/snapmirror on both source and destination.

 

and also please send the output

 

snapmirror destinations

Hi @Naveenpusuluru

 

attaching logs

 

 

 

 

Hi @Santosh_Pandey

 

From your snapmirror destinations out put, i am seeing two same destinations for same volume. Please look at the below output.

 

sm1.PNG

 

This might be the problem. Some one tried to create a one more snapmirror relationship for the same source and destination. Please use the below command to check which is the actual transfer.

 

snapmirror destinations -s <volume name>

Hi @Naveenpusuluru,

 

I dont know how this came up.

 

This is the current output.

 

HORSMHDSGF02> snapmirror destinations
Path Destination
HOROFS02 HORLWHDSGF01:HOROFS02
HOROFS05 HORLWHDSGF02:HOROFS05
HOROFS06 LPLNHFASNFI21:HOROFS06
HOROFS07 LPLNHFASNFI21:HOROFS07_New
HORSNT02 HORLWHDSGF02:HORSNT02
HORSNT03 HORLWHDSGF02:HORSNT03
HORUTL02 HORSMHDSGF02:HORUTL02_NEW
archive_2013 HORLWHDSGF01:archive_2013

Hi @Santosh_Pandey

 

Please try to follow the below process. sometime snapmirrors will be in hung state.

 

snapmirror off

snapmirror on

 

 

and please try manual transfer. It might work in your case. I have tried this when i am in IBM.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public