Software Development Kit (SDK) and API Discussions

NETAPP SLM with single node cluster ontap

Hello Community,

 

I'v install NetApp SLM Version 1.0RC4 Build: 1712060548

 

I'm trying to add single node cluster ontap storage systems.

But it failed to get Capability

Capture.PNG

 

If i try to get Capability by CLI with ontap-performance-sizer.sh

It end with the following error:

 

Invoking sizer module...
Starting the Resource mapping job:
{cot-3-demofr:}-> Sizing Service initialized..
Failed to find /ssl/ssl_configuration.xml.
{cot-3-demofr:}->Building SPM request object...
Getting storage pools details...
Found the hybrid aggregate
{cot-3-demofr:}->Building request object for the SSL 'Value' with peak latency:17
{cot-3-demofr:}->Computing the latency for the aggregates in the node of 'cot-3-demofr-01'.
{cot-3-demofr:data1}->Disk shelf DS2246 found for the aggregate data1.
{cot-3-demofr:data1}->Storage Service Level 'Value' can be placed on the aggregate data1
{cot-3-demofr:data1}->Aggregate data1 can support 7.0ms, IOPS of 5535.61
{cot-3-demofr:data_ssd}->Disk shelf DS2246 found for the aggregate data_ssd.
{cot-3-demofr:data_ssd}->Storage Service Level 'Value' can be placed on the aggregate data_ssd
{cot-3-demofr:data_ssd}->Aggregate data_ssd can support 1.8ms, IOPS of 9569.38
{cot-3-demofr:data_ssd}->Building request object for the SSL 'Performance' with peak latency:2
{cot-3-demofr:data_ssd}->Computing the latency for the aggregates in the node of 'cot-3-demofr-01'.
{cot-3-demofr:data1}->Disk shelf DS2246 found for the aggregate data1.
{cot-3-demofr:data1}->Storage Service Level Performance can not be placed on the aggregate data1
{cot-3-demofr:data1}->Aggregate data1 can support 7.0ms, IOPS of 5535.61
{cot-3-demofr:data_ssd}->Disk shelf DS2246 found for the aggregate data_ssd.
{cot-3-demofr:data_ssd}->Storage Service Level 'Performance' can be placed on the aggregate data_ssd
{cot-3-demofr:data_ssd}->Aggregate data_ssd can support 1.8ms, IOPS of 9469.7
{cot-3-demofr:data_ssd}->Building request object for the SSL 'Extreme Performance' with peak latency:1
{cot-3-demofr:data_ssd}->Computing the latency for the aggregates in the node of 'cot-3-demofr-01'.
{cot-3-demofr:data1}->Disk shelf DS2246 found for the aggregate data1.
{cot-3-demofr:data1}->Storage Service Level Extreme Performance can not be placed on the aggregate data1
{cot-3-demofr:data1}->Aggregate data1 can support 16.0ms, IOPS of 5535.61
{cot-3-demofr:data_ssd}->Disk shelf DS2246 found for the aggregate data_ssd.
{cot-3-demofr:data_ssd}->Storage Service Level Extreme Performance can not be placed on the aggregate data_ssd
{cot-3-demofr:data_ssd}->Aggregate data_ssd can support 1.8ms, IOPS of 9469.7
Failed to find /ssl/ssl_configuration.xml.
Exception occurred while processing command:null
java.lang.NullPointerException
        at com.netapp.apiserver.sizer.spm.SpmServices.getHaPairs(SpmServices.java:875)
        at com.netapp.apiserver.sizer.spm.SpmServices.findNodeThroughputByHAPair(SpmServices.java:702)
        at com.netapp.apiserver.sizer.spm.SpmServices.getSizerResponse(SpmServices.java:228)
        at com.netapp.apiserver.sizer.spm.apis.SPMServicesAdapter.getSPMResponse(SPMServicesAdapter.java:123)
        at com.netapp.fassizer.cli.SizerCLI.parse(SizerCLI.java:245)
        at com.netapp.fassizer.cli.SizerCLI.main(SizerCLI.java:402)

Do you know if this is a know issue with single node cluster ontap storage system?

 

TIA

2 REPLIES 2

Re: NETAPP SLM with single node cluster ontap

NSLM does not support Single node cluster, The support is for HA pair.This is the reason the discovery is failing. 

View solution in original post

Re: NETAPP SLM with single node cluster ontap

Hi pmunshi,

 

Thanks for the clarification

But do we have an explanation of why single node cluster are not supported?

 

TIA

 

Cloud Volumes ONTAP
Review Banner
All Community Forums
Public