Software Development Kit (SDK) and API Discussions

Priv Set Advanced or Diag commands?

I'm trying to run the "sis check" command using the SDK.  i can run it using the "System-cli" NAElement.  But all my commands are running under "priv set admin".  The "sis check" command is a "priv set diag" command.

How can i change my privilege level using the SDK?  I tried running the "priv set diag" command first, but when i next run "sis check" i'm back to "priv set admin" levels...

Any help would be greatly appreciated!




Re: Priv Set Advanced or Diag commands?

If you are going to use System-cli, try  "priv set -q diag;sis check;priv set"

Re: Priv Set Advanced or Diag commands?

Thanks for the reply.  Unfortunately it parses the command and doesn't except multiple commands with a semicolon.  By blind luck i tried the below and it works perfect:

$in =  New-Object NetApp.Manage.NaElement("system-cli");


Hopefully this helps someone else at some point.

View solution in original post

Review Banner
All Community Forums