VMware Solutions Discussions

Can't run discovery in VSC with a domain user


I'm trying to setup VSC with a username other than root in order to restrict access.  I created the role and group and then tried a local username, vsc-monitor.  I modified the credentials in VSC and it worked.  But since I have multiple filers, i wanted to try it with a domain user so i don't have to create the username and password on each filer.  I added the domain user to the same group that i added the local netapp user to and i get the following error:

Missing privileges for username:domain\vsc-monitor,role:discovery

in order to determine which controller privileges are allowed for this username, the following controller privilege is required:useradmin-user-list

please log in using a username with correct privileges. 

Any ideas why that doesnt work?



VSC 4.1 doesn't support active directory accounts on the storage controller - but you should be able to achieve leveraging the same username and passwords on multiple controllers by using the User Creator Tool (which was actually developed by the same engineer who created VSC).

VSC 4.2 (BETA available here) has a lot more options for RBAC, if you'd like to download and test the BETA - you can provide feedback through the VSC community, so you can voice your needs and concerns directly to engineering and development to review.  Read more about the VSC 4.2 BETA from DataCenterDude!!