The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to reigister at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

VMware Solutions Discussions

VSC 2.0 install issue

gary_thomas

Morning all,

Having issues installing the 64bit version of VSC 2.0.

Basically the service won't start, in the wrapper log, it indicates the following.

I suspect there is a licensing issue in play here.

Suggestions?

7/26 12:37:13 | NetApp vSphere Plugin Framework installed.
STATUS | wrapper  | 2010/07/26 12:37:13 | --> Wrapper Started as Service
STATUS | wrapper  | 2010/07/26 12:37:13 | Java Service Wrapper Standard Edition 64-bit 3.3.9
STATUS | wrapper  | 2010/07/26 12:37:13 |   Copyright (C) 1999-2009 Tanuki Software, Ltd.  All Rights Reserved.
STATUS | wrapper  | 2010/07/26 12:37:13 |     http://wrapper.tanukisoftware.org
STATUS | wrapper  | 2010/07/26 12:37:14 |
ERROR  | wrapper  | 2010/07/26 12:37:14 | License Error:
ERROR  | wrapper  | 2010/07/26 12:37:14 | The license keys are incorrect.
ERROR  | wrapper  | 2010/07/26 12:37:14 | Please verify that the wrapper.license.* properties match exactly
ERROR  | wrapper  | 2010/07/26 12:37:14 | and that the following property values match those required for the license:
ERROR  | wrapper  | 2010/07/26 12:37:14 |   wrapper.java.mainclass=org.tanukisoftware.wrapper.WrapperSimpleApp
ERROR  | wrapper  | 2010/07/26 12:37:14 |   wrapper.app.parameter.1=com.netapp.nvpf.container.cli.NvpfServerMain
ERROR  | wrapper  | 2010/07/26 12:37:14 |
ERROR  | wrapper  | 2010/07/26 12:37:14 | A license can be obtained from the Java Service Wrapper site:
ERROR  | wrapper  | 2010/07/26 12:37:14 |   http://wrapper.tanukisoftware.org/doc/english/purchase.html
ERROR  | wrapper  | 2010/07/26 12:37:14 |
ERROR  | wrapper  | 2010/07/26 12:37:14 | Licenses can be generated for any of the following Host Ids.
ERROR  | wrapper  | 2010/07/26 12:37:14 | The first Host Id is recommended.
ERROR  | wrapper  | 2010/07/26 12:37:14 |   Host Ids:
ERROR  | wrapper  | 2010/07/26 12:37:14 |     (removed) (#1)
ERROR  | wrapper  | 2010/07/26 12:37:14 |
ERROR  | wrapper  | 2010/07/26 12:37:14 | Optional host name for license: (removed)
STATUS | wrapper  | 2010/07/26 12:37:14 | <-- Wrapper Stopped
STATUS | wrapper  | 2010/07/26 12:39:59 | --> Wrapper Started as Service
STATUS | wrapper  | 2010/07/26 12:39:59 | Java Service Wrapper Standard Edition 64-bit 3.3.9
STATUS | wrapper  | 2010/07/26 12:39:59 |   Copyright (C) 1999-2009 Tanuki Software, Ltd.  All Rights Reserved.
STATUS | wrapper  | 2010/07/26 12:39:59 |     http://wrapper.tanukisoftware.org

10 REPLIES 10

irlitsolutions

I'm experiencing the exact same issue. Service doesnt start (stops immediately when attempted) and same errors in the wrapper log indicating bad licences keys. I have replicated this problem on two server 2008 servers (UAC on and off) and Server 2003.

glowe

Could you also please file a case with support so we can track the issue? (this was targeted at the folks on this thread that didn't already file a case, obviously )

Message was edited by: glowe

gary_thomas

Solved this issue, the version of wrapper used has a documented bug that invalidates the license in timezones west of Japan.

I downloaded a updated version and replaced the exe and everything is happy.

Guess its just a repackage job for netapp with a new version.

Cheers

fcorfdir

Yes juste reinstall the wrapper standard and the service work. GMT+11 here

Thanks heaps Gary. I installed the new wrapper and this solved my problems also.

glowe

Thanks for your input on this one Gary.  I will be sure that the engineers receive this information.

Thanks for your information as well Greg.

greg_upton

Looks like there is a time-zone bug as I was able to get the wrapper working by changing time-zones to anything west of Japan.

I have logged a case to support.

amritad

Are you able to register the plug-in? Also can you try restarting the service?

Regards

Amrita

gary_thomas

No the service starts, then immediately stops. The log file just repeats what I posted above for the reason its stops.

The log file I posted appears to indicate the service wrapper has a license issue.

Can't register the plugin as the service dosen't actually run to be able to get to this part.

amritad

Could you please file a support case with the logs? IT will help us to isolate the issue.

Regards

Amrita

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public