VMware Solutions Discussions

VSC 4.2X3 Beta Missing storage controllers for provisioning and cloning


I recently upgraded from 4.1 to the 4.2x3 beta release, I am using Edge VSA 8.1.1x39 in my home lab. vCenter and ESXi hosts are all running on 5.1 with the latest patches. Here is a screenshot of the Provisioning and Cloning tab where there are no controllers listed. Nothing else has changed. How can I fix this?


Mike Ellis



That issue was identified and resolved with VSC 4.2 (not the beta, however).

Assuming the controllers all appear in the Monitoring and Host Configuration tab and are properly discovered, then...

You can try this, until the VSC 4.2 is released:

1) Stop the VSC service

2) Delete this from the VSC installation dir:  etc/controllerConfigurations.dat

3) Start the VSC service

4) Wait for the discovery tasks to complete, and then hit Refresh on the Provisioning and Cloning tab and they should appear.


I am having the same issue.  ESXi/vCenter 5.1, ONTAP Edge 8.2, and VSC 4.1.  When I add the controllers under Monitoring and Host Configuration, it says "None" under Supported Protocols.  I have node locked licenses and NFS/iSCSI enabled and running, so this is impossible.  The systems still show up under Monitoring and Host Configuration, but when I go to Provisioning and Cloning, I get the same error (No Controllers found). 


Yes, we had some issues with controller discovery and their display in other parts of VSC outside of Monitoring and Host Configuration.

Did the above series of steps (posted April 11) resolve it?


I just tried these steps above and was unable to correct the problem. I even tried to stop all NetApp services, delete the file, and then reboot vCenter to see if it comes up properly. I am running VSC 4.2x3 (beta)

I also am having an issue adding 2 new controllers to the Monitoring and Host Configuration Tab. Getting the error: "The call failed on the server; see server"

In the VSC logs I see this:

2013-04-24 13:24:31,086 [qtp996627145-25] DEBUG (gwt-log) - [] 2013-04-24 13:23:58,797 [DEBUG] Controller Store contains 0 items

2013-04-24 13:24:31,086 [qtp996627145-28] INFO  (gwt-log) - [] 2013-04-24 13:23:58,781 [INFO ] SUCCESS - ASYNC getControllers() returned 3 controllers

2013-04-24 13:24:31,102 [qtp996627145-25] DEBUG (gwt-log) - [] 2013-04-24 13:23:58,818 [DEBUG] Controller Store contains 3 items

2013-04-24 13:37:22,008 [qtp996627145-25] DEBUG (gwt-log) - [] 2013-04-24 13:36:49,731 [DEBUG] Calling ASYNC getAllowedControllerPrivs()

2013-04-24 13:37:22,024 [qtp996627145-28] DEBUG (DataServiceImpl) - Entered SERVER getAllowedControllerPrivs()

2013-04-24 13:37:22,242 [qtp996627145-28] INFO  (ControllerUtil) - validateController: passed! Controller[ id=b10f7c37-52f5-42df-bcd0-f9bae600727f Name=-unknown- IpAddress= Port=443 Version= ]

2013-04-24 13:37:22,928 [qtp996627145-28] DEBUG (ControllerUtil) - getONTAPIVersion: ONTAPI version found to be: 1.17

2013-04-24 13:37:23,396 [qtp996627145-28] ERROR (gwt-log) - [] 2013-04-24 13:36:51,113 [ERROR] Error: The call failed on the server; see server log for details

Note: is the IP address of some random DHCP device on my network completely unrelated to the NetApp or VMware environment. It is actually an android device. I have no idea where it is getting that from, it has never been used here.