VMware Solutions Discussions

how to edit etc/exports file

goof1427

hi - thanks for your time.   Ill start by saying i'm a noob at netapp and I need a bit of some help.  I want to add some lines to the exports file.  Can it be done through a gui or is it all CLI?

Here is what I am trying to do:

netapp01> vfiler run vfcorp exportfs

===== vfcorp

/vol/esxi01      -sec=sys,rw=10.1.0.1:10.1.0.3

/vol/esxi02    -sec=sys,rw

/vol/vol0  -sec=sys,rw,anon=0

I want to add the IP portion (=10.1.0.1:10.1.0.3) to the esxi02 line...

I am trying to use the wrfile command but I guess I am using it wrong.... I put in the any thoughts?

1 ACCEPTED SOLUTION

SEANMLUCE

I am not sure why modifying the permissions didn't allow the other host to connect.  It could be any number of things.

Once you made the modification, did you re-export the file system from the filer?

Or maybe try rebooting the NFS client?

View solution in original post

5 REPLIES 5

SEANMLUCE

By default there is a Windows share called etc$.  From a windows machine browse to \\filerhostname\etc$, for the username try filerhostname\administrator, and for the password, use the root password of your netapp.

Or use the command line:

priv set advanced

rdfile /etc/exports

<Cut and paste output into a text editor, make your modification, and copy the ENTIRE contents to the clipboard>

wrfile /etc/exports

<paste the entire contents of your exports file>

<press enter>

<press control-c>

rdfile /etc/exports (to confirm the contents are correct)

The key here is that wrfile can only be used to write the entire file.  You can't modify or append using wrfile.

Another option to modify this file would be to mount up the root vol on a UNIX box using NFS.

BEN_HOLKO

you can append to a file with wrfile, using the "-a" command line option

goof1427

seanmluce - thanks for the response.  I opened up a case with NetApp and we did the same.  copied the exact permissions of esxi01 to esxi02. however this still did not allow access to the 2nd volume (esxi02) even though with the same permissions on esxi01 it works fine.  So what I did was open up the permissions with -sec=sys,rw,anon=0 and now it is working.  my only concern now is how secure is the volume now?  ... and why it wouldnt work with the same permissions as it has on vol esxi01. 

SEANMLUCE

I am not sure why modifying the permissions didn't allow the other host to connect.  It could be any number of things.

Once you made the modification, did you re-export the file system from the filer?

Or maybe try rebooting the NFS client?

View solution in original post

goof1427

exportfs -a and exportfs -f  and did a wcc -x ... we did those 3 commands. we didnt try to reboot the NFS client.  I am on the phone with them now.  I will ask them.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public