VMware Solutions Discussions

VSC 7.1 with vSphere 6.7

CommanderBond
22,817 Views

Hello,

 

did anybody try VSC 7.1 with vSphere 6.7 yet? I deployed the VSC appliance, it successfully registered to vCenter as shown in VSC maintenance screen and in vcenter/mob extensionManager, but its icon does not appear in vCenter nor is it displayed in the client plugins list in vCenter 6.7.

I already tried it using different browsers and rebooted the vCenter VCSA 6.7.

 

1 ACCEPTED SOLUTION

konnerth
9,403 Views

Hi,

 

VMware made some architectural changes in 6.7U2 that required additional changes/testing with the Unified Virtual Appliance (VSC/VP/SRA).  We are targeting 6.7U2 support for the UVA with the 9.6 release this summer.

 

---Karl

View solution in original post

101 REPLIES 101

AnotherStorageGuy
5,328 Views

Joe,

Coud you please share the source of 6.7u2 killing the Flash Web Client?


@JAL wrote:

Information I have, is that when ESXi 6.7 Update 2 is released, it will Remove the Web Client and will not be available.

I was monitoring the development of HTML5 Client and VMWare kinda said Flash Web Client would go away in 6.7.0 (https://blogs.vmware.com/vsphere/2017/08/goodbye-vsphere-web-client.html) but didn't happen. BTW I'm all for the Flash Web Client retirement.

Thanks!

konnerth
4,955 Views

@AnotherStorageGuy wrote:

I was monitoring the development of HTML5 Client and VMWare kinda said Flash Web Client would go away in 6.7.0 (https://blogs.vmware.com/vsphere/2017/08/goodbye-vsphere-web-client.html) but didn't happen.


Right, and even that article indicates 6.7 would be the last release for the Flash/Flex Web client:

The next version of vSphere will be the terminal release for which vSphere Web Client will be available.

 

I think VMware may be making some other changes with 6.7U2, but I am not aware that this would discontinue Flash client support.  In any event we are targeting the next release of the VSC to include an HTML5 version with full functionality, and usability improvements.

 

---Karl

 

---Karl

JAL
5,108 Views

I was in a VM 6.7 class 2 weeks ago to try and get some hands on prior to upgrading our 6.0 environment.  The instructor told us 6.7U2 would not include the Web client anymore and move entirely to the HTML5 client.  I haven't been able to verify it but, thought it worth passing along since this thread directly affects us also.

 

-joe

konnerth
4,868 Views

Hi Joe,

 

We confirmed with our VMware contact that 6.7U2 will support both Flex/Flash/Web and HTML5 clients.

 

If you have more details on the class, please send me a private message and I can follow up with the instructor team.

 

---Karl 

ichalac
4,238 Views

Hello,

 

now that vSphere 6.7U2 has been released when can we expect a compatible version of the VSC?

 

Thanks.

konnerth
9,404 Views

Hi,

 

VMware made some architectural changes in 6.7U2 that required additional changes/testing with the Unified Virtual Appliance (VSC/VP/SRA).  We are targeting 6.7U2 support for the UVA with the 9.6 release this summer.

 

---Karl

konnerth
4,958 Views

Hi,

 

I am happy to announce that we have posted VSC 7.2.1P1 today, which addresses the upgrade failures seen by some customers.  It has been tested with a broad variety of upgrade sequences, including those I described in my earlier message.  Just go to download 7.2.1, and you will be directed to 7.2.1P1.

 

I am also happy to announce that we have updated our IMT listing to clarify that this release is supported with all vCenter 6.5 releases as well as vCenter 6.7 and 6.7U1.

 

It's just a happy day for me.  🙂

 

---Karl

 

JeremyS
4,926 Views

are there specific reasons VSC 7.2.1 does not support ONTAP 9.2, but supports ONTAP 9.1?  or is this misinformation in the interoperability matrix?

konnerth
4,913 Views

We didn't include 9.2 as this release is now in limited support.  The listed four releases are in full support:

https://mysupport.netapp.com/info/web/ECMP1147223.html#ontap_svst

 

jakari
4,646 Views

First off, thanks to everyone at NetApp who got this out the door when promised.

 

I'm reading about people doing upgrades with vSphere/vCenter 6.0 but the IMT doesn't show that as compatible with VSC 7.2.1.  Is that an oversight, or is it actually incompatible?

 

Secondly, VSC 7.2.1 (SRA) doesn't seem to be supported with SRM 6.1.2.  Anyone know if it at least functions for the purposes of an upgrade?

 

I have a somewhat complicated upgrade path, starting with vCenter 6.0, SRM 6.1.2, SRA 4.0P1 (appliance) , VSC 6.2.1 (Windows), ONTAP 9.3.0 across two sites.   Desired state is vCenter 6.7U1b, SRM 8.1.x.  I don't really care too much about VSC, but SRA+SRM ideally wouldn't require much reconfiguration.

 

In theory, being able to get the VSC appliance up and running with vCenter 6.0 first, and working with the existing SRM version, might make it smoother.

 

I'm starting to feel I'll be better off just de-registering SRA+VSC and installing the new appliance from scratch, and taking the hit for however long it takes to get SRM to find its storage again...

 

larryblanco
4,989 Views

Is today the day?  7.2.1 for vSphere 6.7.x?

 

 

Chittaranjan
5,069 Views

The date for posting UnifiedAppliance 7.2.1 (which includes VSC, VP and SRA) is 24 Jan. The build is ready and we anticipate no delays or challanges to post it successfully.

 

Regards,

Chit

displayname0
12,167 Views

Please get this going ASAP! Or give us a beta or even something with limited functionality.

konnerth
12,123 Views

Hi,

 

Just to confirm other NetApp responses on this thread, we have committed vCenter 6.7 support for the next VSC release (7.2.1, planned for December release).

 

ONTAP NAS and SAN have been qualified for vSphere 6.7, and NFS VAAI qualification is underway (but we have identified issues with VMware NFSv4.1 support in recent vSphere releases).

 

I hope this helps.

 

---Karl

Mordock
9,102 Views

Well, it's December, we are waiting.

Mordock
11,519 Views

With vCenter 6.7 Update 1 now GA, NetApp support for vSphere 6.7 is even more imperative.  Update 1 brings several new features especially the re-embedding of the PSC's that many of us have been waiting for.  Please expedite the release of 7.1.1 or whatever version will support 6.7.

nobenhoffer
10,705 Views

You guys really need to get things out there.  It feels like you don't really want to support vmware.  You take forever to support current versions of vmware products, you are ripping out features with each new release, and just don't seem to care.  

konnerth
10,697 Views

Hi,

 

We do care about our customers who use VMware vSphere with ONTAP, and have been investing significantly in tool and ONTAP development to support it over the past few years.  Much of that has been on the VVol side recently, but we also have updated VSC and SRA with new capabilities and support.  We have several sessions at Insight in Las Vegas that cover this:

  • 1198-1 - Managing Storage in vSphere with Unified Appliance 8.0
  • 1120-2 - Best Practices for VMware vSphere and ONTAP: All Flash FAS, Hybrid Cloud, and Beyond
  • 1113-2 - Using VMware VVols to Simplify and Automate Your vSphere SAN Storage

It might seem like a simple thing to support vCenter 6.7, but it was a major effort to support it along with earlier releases.  VMware updated the Java libs, which impacted other components we used.  Some changes were obvious, but others only came out through extensive code review and testing across multiple vSphere and ONTAP releases, and working with VMware.  Our development and QA teams are focused on releasing this as soon as possible.   

 

If there are features that you are missing, please let me know.  The features I'm aware of that were removed either were obsolete or not widely used by our customers.

 

---Karl

henk_ruis
9,399 Views

Hi,

 

Is there an update when the VSC 8.0 will be available?

vSphere/vCenter 6.7 U1 is available for a while and we want to use this integration with NetApp within the vCenter.

 

MicheleD
7,677 Views

Hi Karl,

Any news on the next version of VSC with support for VMware 6.7?

Also do you know if it would be possible to upgrade from current VSC 7.2 or would this be a fresh install?

 

Thanks

Michele

konnerth
7,668 Views

Hi,

 

We are still on track to delivering, but it will likely be towards the end of the month.

 

It should be an easy upgrade from 7.2.

 

---Karl

Public