VMware Solutions Discussions

VSC 7.1 with vSphere 6.7

CommanderBond
22,824 Views

Hello,

 

did anybody try VSC 7.1 with vSphere 6.7 yet? I deployed the VSC appliance, it successfully registered to vCenter as shown in VSC maintenance screen and in vcenter/mob extensionManager, but its icon does not appear in vCenter nor is it displayed in the client plugins list in vCenter 6.7.

I already tried it using different browsers and rebooted the vCenter VCSA 6.7.

 

1 ACCEPTED SOLUTION

konnerth
9,410 Views

Hi,

 

VMware made some architectural changes in 6.7U2 that required additional changes/testing with the Unified Virtual Appliance (VSC/VP/SRA).  We are targeting 6.7U2 support for the UVA with the 9.6 release this summer.

 

---Karl

View solution in original post

101 REPLIES 101

konnerth
4,657 Views

6.7 and 6.7U1.  But see my earlier note in this thread if you use NFSv3.

 

---Karl 

robverhoeven
4,761 Views

VSC 7.2.1 is available for download: https://mysupport.netapp.com/NOW/download/software/vsc_win/7.2.1/

 

The virtual appliance for VSC, VASA Provider, and SRA provides the combined features of VSC, VASA Provider, and SRA in a single deployment. VSC features are enabled by default when you deploy the virtual appliance.

Depending on your requirements, you can enable VASA Provider or SRA by using the virtual appliance for VSC, VASA Provider, and SRA. The virtual appliance supports the following features:

  • Support for VMware vSphere version 6.7 and 6.7U1
  • Support for ONTAP version 9.5
  • Support for IPv6
  • HTML5 compatible plug-in available for preview
    You must use the HTML5 feature only for lab environments. NetApp does not provide support services for any of the features or functionalities that are available in this technical preview.

JamesC
4,726 Views

Tried upgrading from 7.2 and although the system reports as successfully upgraded the appliance then fails to boot.  There seems to be numerous errors but rolled back to 7.2 in the end.

 

Has anyone else managed to successfully perform this upgrade?  Will log a support call next week if no one else has this issue.

sillywalk
4,551 Views

Errors seem to be with some package removal requested in the upgrade script. Rolling back.

Hakan
4,427 Views

Upgrade failed for me also.

satishv
4,546 Views

Do you have a screenshot of the errors? Also which version of vSphere is the appliance deployed on?

Hakan
4,544 Views
Hypervisor  Version  6.5.0, 8294253
Vcenter...
Version: 6.5.0.22000 build: 9451637

 

1.JPG2.JPG

JamesC
4,516 Views

I have the exact same error.  Tried upgrading vmtools before before upgrading to 7.2.1 but still had the same issue.

 

To confirm vmware tools did upgrade successfully without causing an issue.

Hakan
4,316 Views

any news on this topic?

 

larryblanco
4,397 Views

Same exact issue here with the upgrade.  Fails with the same issues as described previously here.  

 

I do have 2 virtual centers and did a new install of 7.2.1 from OVF. That install went on without a hitch.   

 

LB

 

 

satishv
4,335 Views

For the upgrade issue, can you share the screenshot of the errors?

Hakan
4,324 Views

There are screenshots in an earlier post.

JamesC
5,432 Views

It would seem that mutiple people have the issue with the upgrade and screenshots have been provided.  Can someone from NetApp acknowlegde this and that a fix will be released soon please?

satishv
5,427 Views

Have you verified the VSC plugin after the upgrade. Especially in the About page on the VSC dashboard. It would show the 7.2.1 version.

 

Also, can you check if you are able to perform VSC operations if the about version shows as 7.2.1

JamesC
5,424 Views

After the upgrade fails the applicance fails to reboot.  If you then manually restart the appliance it fails to boot at all and just hangs on startup.  Obviously any tests of the plugin atre not posssible.

 

 

satishv
5,577 Views

It looks like you are upgrading from 7.0P1.

The supported upgrade paths are from 7.1 and 7.2.

JamesC
5,573 Views

 I'm upgrading from version 7.2 and I have the exact same issue.  See below screenshot from the "About" tab on my exisiting installation.

 

Untitled.png

Hakan
5,557 Views

It looks like 7.0P1, but it's only name of the guest i vsphere that is not updated. It's 7.2 for me also.

Mike_Ryan
6,317 Views

I am on VSC 7.2 and the upgrade failed in the same manner as Harkan

konnerth
6,275 Views

Hi,

 

I am sorry you are experiencing these problems.  Engineering has been following this thread and is investigating.  I just tried to upgrade my lab system and saw similar.  

 

It's possible these are related to vCenter release.  I have been working with Engineering to clarify the supported releases as listed in IMT.  Has anyone had problems when upgrading using the vCenter releases that are currently listed in the IMT (6.5U2, 6.7 and 6.7U1)?

 

---Karl

larryblanco
6,266 Views

netapp is able to recreate the issue when upgrading..   See below:


Thanks for your feedback

 

We were able to replicate the error reported. We submitted this report to our Engineering Department to investigate.
If version is necessary on your environment, two (2) scenarios are available as a workaround:

 

  1. Freshly deploy VSC 7.2 appliance and then, upgrade to 7.2.1 (no issue found when tested).
  2. Fresh install of VSC 7.2.1 on your environment.
  3. Rollback to 7.2 using an available snapshot (if taken before the upgrade).

 

If scenarios 1 or 2 are not possible and the rollback to 7.2 works for you, our suggestion is to keep it as it is while our Engineering Dept. provides a fix. At the moment, no ETA has been provided (yet).
To follow-up on this, please refer this BURT ID: OMITTED

 

Given that this situation depends on a higher department and has been already escalated through the BURT provided above, is it safe for us to archive this case here at Technical Support?

 

 

Public